I am ready to purchase the full version except for one small detail…When I try to add effect to track, Boom! Ntrack is gone, back to Windows desktop. If this is a function of demo version, no prob! If I pay $75 & it still happens, big prob! Running XP pro on 750 PIII with 800 megs memory & dedicated SCSI 20G drive. Using M-audio USB interface with ASIO drivers. I have also tried shutting off all non essential programs at same time. This happens whether I’m dealing with 1 track or 4. Any thoughts anyone?

No, that’s not a function of the demo. I suggest you email Flavio with the details of the plug-in and exact steps that got you to the crash. You should be running smooth on WinXp and a 750 PIII. That’s what I’ved been using for years. V4 is relatively new so there are still a few bug in it, but Flavio is REALLY good about fixing them quickly. If you are having problems with V4 and still want the full version he may set you up with V3.3, which has been very solid for a while.

does it do this with directx or vst or both types of effects?>
mine would crash with directx until I unchecked “multithread directx plugins” in the preferences. works fine now.
vst didn’t have any trouble though.

OK, cool. I unchecked the multi thread deal & it no longer crashes…Great! Now as soon as I hit play, no more mouse or keyboard action! I get to wait until entire file is done playing before I can tweak ANYTHING. This is making it rather difficult to adjust the sound. Ergghh… Getting rather frustrated. Does everybody have this much trouble getting the basics working??

Hi Storm,

You should be OK with your system. I ran n-Track on a PII 450 with 96 megs of RAM for a year or two with no problems except for the occasional “rogue” plugin. I would do as Phoo suggested. Drop Flavio a line from the Support page and I betcha he fixes you up.

Welcome to the forum BTW!!


I run Ver 3.3 on a PIII 800 Mhz CPU / 384 Meg of RAM / XP Pro / 40 and 20 Gig 7200RPM hard drives.

Never got the DEMO version of that one running correctly either but bought it anyway about a year ago, assuming that it had to work eventually.

Don’t know what the problem was but when I paid the money and got my registration number it worked fine.

I haven’t wanted to mess with upgrading since things seem to be running fine now and it will take me the next 10 years to figure out all the features of 3.3.

Quote (Airstorm @ Oct. 19 2004,18:45)
OK, cool. I unchecked the multi thread deal & it no longer crashes...Great! Now as soon as I hit play, no more mouse or keyboard action! I get to wait until entire file is done playing before I can tweak ANYTHING. This is making it rather difficult to adjust the sound. Ergghh... Getting rather frustrated. Does everybody have this much trouble getting the basics working??

Look at two things when you get the lock up. First, what is the CPU usage showing up at? (N shows you in the lower left) If it is 90% or more, you have too many plugs going probably. I doubt you do though with what you described. My guess is that it is a buffering issue. What drivers (MME, WDM, ASIO) and sound card do you have? Do you have the latest drivers? How are your buffers set and where did you set them? Also, have you enabled DMA for your hard drive. By default XP enables DMA if it is available, but it is worth checking. Sometimes the BIOS needs a tweak to enable DMA for the hard drive's controller.

try raising your playback buffers. if my recording buffers are too low, n-track won’t respond to commands either-but it won’t play sound as well.

it sounds to me like it’s a buffer issue.

go to the playback vu meter-click on the hammer, and click on asio settings-raise the buffer a bit. if you’re not recording with live input processing, you can raise it a lot since you won’t notice a latency problem (you’ll be monitoring your input from the soundcard’s control panel-if it doesn’t have one, the recording vu meter’s hammer button will open up a panel with two faders/pan pots-these are ASIO monitoring faders, press monitor and you should hear the input of your soundcard)

{Starts with long exasperated sigh}
I have tried different buffer settings from high to low & everything in between. 1-4 tracks will play back fine with good quality audio & no lags between tracks. It’s just that while sound is playing I cannot click or move the mouse, & the screen freezes. It will play the entire song perfectly like this! When the audio ends the screen wakes up & VISIBLY plays the whole thing almost like it’s in fast forward, after that I have control again. This almost resulted in a nucleor blast a couple days ago because I tweaked a couple volumes WAY too high and the resulting playback went way beyond clipping. Luckily I have instant off turned on for my power button! I decided to buy it hoping I would lose some of the bugs & guess what? It won’t accept the (&&^%#&^ codes! I received something that looks like this:
Unlock code - This doesn’t look like 2 separate codes to me…But hey, I’m just a dumbass drummer…Right? I have tried putting the sets of numbers in every way I can think of. Comes back with wrong registration codes entered message every time. Am I missing some grand magical sign that unlocks the key of knowledge for this program or what???? I have reached being pissed off at this point which is extremely rare for me. Does everyone else’ unlock code look like this format? Also; I got pointed to some third party site to pay the money, is that normal… Or did I get screwed?


Payment is handled by a third party (that’s normal) and your codes seem right. They are in the form of 111111111 - 111111111. The two parts separated by the -. Leave out the spaces. You didn’t get screwed on that part, though occasionally the company that handles that stuff will send out some codes that are on the pirated list so n-Tracks refuses them. If that happens email Flavio and he’ll get good codes to you.

The more I read this thread the more I think this might be a USB conflict. I don’t remember the fix but seems like someone else had a similar problem with his mouse jumping all around. I hope someone else remembers. There were some USB problems in original WinXp, but installing SP1 would fix it. Since you have SP2 I doubt you’re having the same problem.

Is there any way you could try a non-USB card to see if the problem goes away? Do a second check for latest drivers, including video drivers. It can’t hurt.

There have been several complaints about registration in the past (including mine). When I registered, I got an email saying, “You’ll find the registration code at the bottom of this email”, but when I reached the end of the email, no codes whatsoever! Course, I wasn’t very happy, and I ranted on the forum (I’d point to it, but the forum has since been wiped out). Anyway, I fired off a few emails to, did some waiting, and eventually got it straightened out after about a day and a half.

So, three things: (1) Fasoft uses the third parties Digibuy and SWReg for registration, (2) Reg issues are not uncommon, and (3) they mostly seem to get resolved within a day or so. I feel for you, man, I really do. I hope you get it resolved quickly, and that the whole reg system gets fixed soon.

Anyway, assuming you get your reg codes very soon, your biggest problem still sounds like your system. I second phoo on checking out the USB aspect of this by trying an internal card.

If you can’t get a card for a while, you may also try out other recording software (like the Sonar demo, etc.) just to see if they behave the same way. I would import the wav files from your N-track project and try to use the same or similar effects. If you don’t have similar problems, we can go from there and focus on N-track. If the software behaves similar to N-track, then it may be a system-wide problem, like the USB interface or some background service eating up resources, etc.


Don’t have any burnable time til tomorrow, but the USB bus is free of any other hardware & all other programs & processes have been shut down to eliminate system bog. In case I didn’t mention it…Cpu load is in the 40’s. Can’t tell what it is with efx on because of screen lock. I will check on service packs tomorrow. Thanx for the support from all, at least I don’t feel alone! :)