Aux sends not saved in song

I’ve been using N-Track for about 8 years, yet here I am asking questions like a noob…
For various reasons, I still use N-Track 2.3 on one of my machines, and I’m happy with it, but have bought V5 and now V6 for another machine.
I’m still trying to get familiar with V6. I figured out how to do the AUX sends, how to set pre/post fader, etc. I get all the settings the way I want them with the effects on the AUXes and save the song file. When I reload it, the aux sends are gone. It’s not just a matter of the send buttons not showing, there are no effects so that means the entire send chain is lost. I’ve looked at all the settings and can’t find what I might be missing. Anyone have any clues?
Also, I am unable to get any DirectX effects to show up, including the ones that are supposed to come with N-Track (compressor, echo, chorus, etc)

Forgot to add - the aux returns DO show up on the mixer, along with the associated effects.

I understand about not showing auxes. BUT, if I define an aux send or two, chances are that I wish to minimize CPU load by defining an effect common to multiple tracks. It would seem to make sense to default to sends for each track on the mixer. Those could then be selectively disabled if needed, if that feature is deemed desirable, although I cannot see any real advantage over just dropping the level to zero…
I must admit that I’m an embedded systems designer/programmer (in low-level languages) and not familiar with any Windoze APIs.

Guess noone else has had this problem…

Hi Kr,
I’ve read your thread and unless I missed something you appear to first say the aux channels don’t save.
Then you added that the effects don’t show up.
Then you reiterated saying the aux show and save as do the effects.
What is it that your wanting?
I personally don’t use aux channels at this time, sorry.
But maybe you could simplify your wording to a more specific question about something or other :laugh: I appreciate you discussing and experimenting!

Quote: (krbaker @ Jan. 23 2010, 10:11 PM)

It would seem to make sense to default to sends for each track on the mixer. Those could then be selectively disabled if needed, if that feature is deemed desirable, although I cannot see any real advantage over just dropping the level to zero...
You know versions 3 and 5 they did default didn't they?
Flavio is always listening for ideas.

Sorry for the confusion, guess I should’ve been more clear.

I can’t get the DirectX effects to show up at all, actually a totally separate issue from the AUX send issues.

While getting my mix together, I set up my AUX busses for common effects, such as echo, reverb, etc so that I can use one instance of the plugins to save CPU resources. I can get all those going fine, get my effects levels set for the AUXes, etc - all sounds good.
I then save the song file. When I reopen the song file, the AUX sends are NOT shown on the tracks on which they were set. The AUX returns DO show up, and the effects list in the AUX returns are right. The effects that I set on those tracks are not audible, which tells me that it is not simply a matter of the send controls not being displayed, I am actually losing the AUX send levels.

Hope that clears up my problem, and thanks.

Levi, how do you NOT use AUXes?? Surely you don’t add reverb to each channel individually?

I personally liked the fact that earlier versions automatically displayed AUX sends on each channel. I understand that some people prefer to not show them if they aren’t used. However, doing it that way makes the mixer more jumbled because the channels with AUX sends have different sized controls. That’s just my opinion, though.

I could live with the mixer displaying AUXes only on the channels where I’m using them,
but to not have the AUX sends saved is going to be a dealbreaker for me.

I just added an aux on the demo song, (using ADD CHANNEL on the toolbar)
Then added reverb to the aux channel. (large hall preset)
I then sent track 2 to the aux channel. (using output channel select of track
Then clicked on aux in the track 2 channel output and selected ‘add new send’.
I set the send to +2.2 db. Panned the send all the way to the right.
Played the demo song - soloing track 2 and heard the reverb in the right channel.
I then saved the song as auxTest.sng (Remember to say YES when it asks if
you want to save the changes to auxTest.sng)
I then reloaded auxTest.sng. And my aux channel, send for track 2 ARE there
with the reverb in the aux channel and the send level is correct at 2.2db and
is panned right. And the .sng played back the way I had saved it.
So I am NOT seeing the problem you are having.
Try that simple test and see if you get the same results.
If you do, then I would suggest that you may not have saved your aux setting
changes correctly.
Hope this helps.

I am using build 2514 for the above.

I’m pretty certain that I saved the song file after adding the auxes, but I’ll try it again after work. I really appreciate you trying it out and giving me some feedback.

I’m mainly using the latest version to capture and “rough mix” 14 simultaneous tracks at practice so that I can put together some band demos. I’m still using V2.3 on my main DAW, even though it’s an old version it’s been solid. I’ve had some issues with versions since then, thus my reluctance to upgrade that machine until I can be reasonably certain that all is working well.

I’ve got some demos from my previous band here:
and some non-band stuff on my MySpace page:

Some exquisit guitar, KRB.

Yup - those are some ‘ready for prime time’ tune’ages :agree:

Okay, here’s the scenario under which my AUX sends are not saved:

1. I click on the “Channel Output”. I select “Add new send”. This leaves the main output going straight into the mix, and gives me a send for just effects. I setup the AUX send post-fader.

2. I setup the AUX return with the desired effect, set to all wet so that the AUX return controls just the routed effects.

3. I adjust send and return levels appropriately to get what I want. When done, I save the song file.

4. When I reload, the sends that I setup on the channels are missing, and there are no effects. The AUX returns are reloaded properly.

Note that this is the “standard” way of using AUXes, at least as far as hardware mixers (and earlier versions of NT). Sevenofeleven earlier set up the channel output to AUX, but that routes the channel only through the AUX and pulls it out of the main mix. Definitely not the same thing as adding an AUX send.

Thanks for the compliments on my tunes. Maybe one of these days I’ll be able to find some time to actually finish up some originals…

Man - I hate to be a ‘contra’ - but again I tried it with the demo song
as you said. That is (in this case track 2 of the demo song) I created
a send for that track. Put a reverb in the created AUX channel; then adjusted
the AUX return to 0db. (left the send at 0 as well).
It’s doing what it’s supposed to - that is sending track 2 to the AUX reverb.
Now when I save, I do a FILE/Save AS
then I do FILE/Close Song, at which
point it asks me if I want to save the changes to c:\filename. (the file I
just saved) And I click the YES button. – When I reloaded that .sng, everything was there.
I am wondering if you have set in the track mixer - to SHOW AUX’s &
SHOW AUX/send/returns - Not sure if that makes any difference, but I have
those set.

Yes, my track mixer is set to show aux channels and sends/returns. I tried it again just now, and still no save.
I created an aux send with reverb, all is good. I save the song file. When I reload, the aux send is not there, and no reverb on that track. When I again add a new aux send, it gives me aux1, which should have been reloaded with the song, therefore it is NOT saving the send in the song file. Frustrating…

I’ll post screen captures if I can.

Okay, I’ve got screen captures. I’m not going to post here, so as not to force anyone reading this thread to download images.

Here is the song setup after saving, just prior to exiting NTrack:
Saved song prior to exit

On the screenshot, AUX1 can be seen on channel 1. I’ve also got the track mixer settings shown. I verified that the AUX1 effects are easily audible (drums swimming in reverb
:) )

I exit NTrack, then immediately relaunch it and reload the song just saved. Here’s what I get:
Reloaded song

AUX1 is gone. There is no reverb on the drums. When I add an aux to channel 1, it adds AUX1 again, so the prior setting was not saved for some reason.

I have the same or similar problem, I have an aux send on track 1, tracks 2 thru 8 are midi tracks. Record a new track, there is no aux send on it, but is still there on track 1. If I slide it up to become track 1 the send is there, but it will not move. This is with v-6.05.

I’ll post a .flv (flash) video sometime this afternoon.
I duplicated your setup - even added 4 Aux channels. Sent 1 track
to Aux1 with a reverb, sent another track to Aux2 with an echo, put
in some send/return settings, changed pan settings and saved.
They came right back when I reloaded.

(I did notice on your second screen shot, that the track strips are
larger. I guess you tried re-sizing it to see if the send was below, but
was not visible because of the size.) Ya know under size in the track mixer
- select smaller or something.

Seven, the track strips are larger 'cuz my auxes are missing… :) The strips are automatically reduced in size when I add auxes. I have verified that the auxes are really not there upon reloading - no visual, no audible.

I guess my only option at this point is to reinstall (again) and hope for the best. If that doesn’t work, I guess I’ll have to drag out the Cubase that came with my audio device, which I really don’t want to do.


... 'cuz my auxes are missing....

Yeh - (you know your way around N ) Anyway, here's a realtime
flick of what I get. (with pauses because of CamStudio limitations)

I used build 2526 for the vid - but 2514 works as well for me.