MSVCR80.dll missing error


I was finally able to install the new beta version, but now when I go to start up the program, it says that MSVCR80.dll is missing, and that a reinstall will probably take care of the problem. But a reinstall does not, and I searched, and the file is there, in some folder windows/winsxs/x86 blah blah blah.

Now what?

If I wasn’t so stupid… I’d say that something is a-miss in the install exe that Flavio has posted… But… after haveing said that… why has this machine recovered from all that has gone on with IT today? I did a search for MSVCP71.dll and IT wasn’t found on or in windows sys32 folder… on this “C” drive… But continuing the search IT was found on most of the other drives that had an operating system installed them… “In-the-Past”… go figure that out…

I never started playing with any of them, though… I let them be… wherever they were… found…

In fact, I’m gonna do another search for that file on my “C” drive right now… to see if it’s in fact there…

And yes… It’s there in several places on my current “C” drive…


Remember… the issue on this machine is /was with MSVCP71.dll

MSVCP80.dll ????? Was your machine built in China?? or some other foreign country? hehe…


Yeah, in Flint, Michigan, definitely a foreign country, especially if one hails from Canada. :)

O.K. O.K. I get IT… I was refering to MSVCP80.dll… But you are looking for MSVCR80.dll

That’s different… lol… I think if you go south… you’ll find that file down in Florida… That file always goes south for the month of March… :O :laugh:

I think it’s at a place somewhere north of Orlando… Try the Cosy Inn… I forget the phone #


There are three files together, MSVCR80.dll, MSVCP80.dll, and MSVCM80.dll, all in the same folder as noted above. They are all there! The one it says is not there is there! I tried a “repair” of the net 2.0 thing, and reinstall of n-Track, but still same error!

Well, I’d better figure this out - I have folks coming to record in a couple of days.


Hi Tom:
I did a search on those three files on this machine. They are in the folder you mentioned, in your post… x86? whatever… ??

Anyway, on this machine there are two versions of each .dll

Something like v8.0.50215.44 and v8.0.50727.42

They range in the order of 408 kb. to 612 kbs.

I have no idea what and how they work… But If you just copy-and-paste them in there will they work normally? or do they need to be installed there by some process? Or what do you think ??

I have this preminition… Look out… Do they have something to do with .NET Framwork? or something?


Tom, the files may be on the PC but they still need to be in Window’s search path for it to find them.

Try copying the files to C:\windows\system32 (assuming Windows is installed to the default folder and we’re talking about XP)

… or as a last resort, copy them to the n-track program directory.



Quote (TomS @ Mar. 26 2006,16:51)
I was finally able to install the new beta version, but now when I go to start up the program, it says that MSVCR80.dll is missing, and that a reinstall will probably take care of the problem. But a reinstall does not, and I searched, and the file is there, in some folder windows/winsxs/x86 blah blah blah.

Now what?

Someone reported a similar problem which appeared to be caused by having “Zones Labs Security Suite” running while n-Track was being installed/launched.
Try uninstalling n-Track and reinstalling it after having closed all system monitoring software such as antivirus, anti-spyware etc.
The DLL should be in the folder c:\Windows\WinSxS\x86_Microsoft.VC80.CRTxxxx


Thank you, Flavio! The DLL file in question is in the proper location, and the machine I use for recording has no anti-virus or anti-spyware software on it. It has n-Track and a couple other audio programs, and that’s it. It’s a very clean machine. :)

I’m going to work on it this afternoon and see what I can come up with; I’ll report back the results.

Mark - yes, XP, I did a little googling, and found that putting the DLL file in system32 was not the answer, according to someone who wrote the DLL, and that putting it there might cause problems down the road.

Here’s a question: I did not update with SP2, I only grabbed Windows installer 3.0 to install the net 2.0 thing, and then the program. When I was installing the new beta of n-Track it said that I needed to uninstall the old version, and I said “yes,” but when it came back it told me there were still components that needed to be uninstalled, and told me to use the “uninstall program” feature from the control panel. I did that, and told it to uninstall all components.

Well, I think I will try installing all of SP 2 first.

As I said, I will report back.


TomS…just $.02
Maybe you already know – watch out when using SP2…I believe it has a built in firewall and other security ‘enhancements’(?). It gave me a bunch o’problems blocking everything, everywhere when I was setting up a home net.


Hi Cliff:
You are right… This Home Network works very eratict, at times. I’m never quite able to predict when IT works and when IT’ll not look at hard drives on the other machines, when they are fired up… It’s very frustrating… But your explanation is “Right-on”. Now that I think of it… In one direction it’s lightening fast in another direction IT’ll take all day to transfer files… I can never predict in advance how the network will behave… Then I do a reboot of the machines, and all is O.K. But I never seem to know… I expect it’s some config. with the D-Link Network adaptors. ?? I cross my fingers at times just hopeing I’ll be able to see drives, on other machines when I need to see them… Other times I can “Stream” 20-25 tracks like there’s No Tomorrow…

Could IT be some hardware missbehaveing? Mabey, the Hub/Switch? I don’t know… I know something is wrong when the machines start looking for new IP Addresses… Mabey, IT’s a sequence of booting up the machines… ??

Sorry Mark… getting OFF-Topic…


Thanks Cliff, that’s good to know. The computer in question is my recording one, and I have kept it very clean; I don’t plan on sticking it in a network or anything other than recording. Hopefully I will be able to avoid more problems that way. In any case, it’s getting close to time to upgrade anyway. It’s an older p4, and I clearly need more RAM and power to run the Garritan Personal Orchestra I got for Christmas. :D

Nope, I still get the same error message.

Any ideas, anyone?

Hi Tom:
This has to get fixed… I’ve been thinking about this issue… I’m sure you’ve considered a system restore… That’s kind of easy… But I’d start there… At least you’ll have the last working n-Track version… I think… But, beyond that… here’s what passed through my thoughts…

This could involve some thoughts and advise from some of the guys here on the Board…

The correct way to approach this may be above my ability to rationalize this…

1… Remove n-Track from the registry, and reinstall IT from the “Ground Floor”… But that’ll include installing all your FX and whatever else may be required to config. the editor from the “Beginning”… If you do that… What build do you begin, with? The answer is… the build/version that does not require .NET Framwork… Then… The next build to install over that would be The build that requires .NET Framwork… But install that build from the LARGE FILE that Flavio posted…

OH yes… uninstall/delete .NET Framwork from your ADD/REMove list… Install .NET Framwork from Flavio’s files… (Including your Reg. Codes) Just thinking… Mabey, someone has another approach? After you get a build going that .NET Framwork likes then update to the latest build… Today… 2080…

What makes me think I know all about this? I don’t know… I’m hopeing that a reply from you geeks can suggest a FIX for Tom… and get him into v4.2.0… There’s the "Right’ way to get this going for Tom… Any other way is gonna cause a lot of grief for him-and-his set-up…

I don’t know how I bridged the up-grade from build 2037 to 2042… Then to up-date n-Track yesterday from v4.1.6 build 2065 to 4.2.0 build 2078 then to 2079… I may still have some issues that I have yet to encounter… Who knows?

Anyway, I’m downloading build 2080 and I’ll install IT this evening, sometime…

I’ve set a new restore date… as of today… We’ll see what happens…


Well, I uninstalled net 2.0, and reinstalled 4.0.5 build 1848 or so, whatever it was that I had before, and everything is smooth again. I think I will wait until I have a free weekend, and tackle the whole issue then. I do have the new beta version on my general use computer (the one I’m using now) and the drum machine is totally cool - very nice sonds, nice bunch of beats and grooves for sketching out songs, so I will most certainly want to solve this at some point, but for now things are back to where they were and apparently stable again.

And n-Track is still the coolest thing I have ever owned, except for maybe my first Ric 370 and Vox AC30 combination way back when both could be had for next to nothing and I didn’t know any better and lusted after a Les Paul. :D

Hi Tom:
That sounds so good even from here…

I’ve looked at this drum machine… But not for more than an hour-or-so… I’m not so sure that I grasp the concept of IT yet… I placed a snare track on the time line… But I don’t know quite how to replace the sound that the track contains with the new sample of what I’d like to hear… Is that something that is possible with this VST utility?

What if I wanted to import a kick into the timeline? and substute the kick with another sample?

Am I on the same page when thinking along these lines?

A few years back I was in central Tennessee talking with the guitar player on Brian White’s stage… after they had done their show… Anyway, I was makeing reference to the AC 30 amp he was useing , that day… This amp was brand new… Never had a mark on IT anywhere… So, I asked him if IT was a real one or a fake one… He knew what and where I was going with the question… His reply was … It better be a real one… He paid 2400.00 for IT… This guy uses two amps on the stage… along with I saw 5 different types of guitars… on his guitar stand… Anyway all this stuff is wireless… no wires to be seen anywhere…

The other amp was a "Black-Faced Twin… But that amp looked like a re-issue amp… to me… at-first-glance…


Hmmmmm…after reading the above…
I am still leary about installing 4.xx on my machine. I purchased it (4.xx) just so I could get 3.3 which is very stable and does pretty much what I need it to do. After reading comments about new features in 4.xx I am very tempted to go ahead and take the plunge…then I read a post about a problem.

My system with 4 boxes networked for storage is so stable (probably shouldn’t have said that) I just don’t know if I need to mess with it for some new “bells” - which I can produce with MIDI.

Then there is the question of an upgraded version reading projects made in a previous version. I am still dealing with that after going from 2.xx to 3.3. Will that happen if I go up to 4.xx?

Should I or not? I really want to.

oops…guess I got off Tom’s topic…sorry


Nope, that’s on topic. The temptation to upgrade is strong even in cases in which the new features are not ones I might use. At least that’s what I’ve found about myself with regard to other programs. If it works, don’t mess with it, until a clear need is present, that’s my new motto. :)

Quote (TomS @ Mar. 27 2006,19:48)
Nope, that’s on topic. The temptation to upgrade is strong even in cases in which the new features are not ones I might use. At least that’s what I’ve found about myself with regard to other programs. If it works, don’t mess with it, until a clear need is present, that’s my new motto. :)

Hmmmm. So you’ve left the progressive camp and become a neocon?

If you go to the Net page (Microsoft) and look at the requirements…it states SP2 and doesn’t mention SP1.

On all the computers we upgraded to SP2 only 1 gave us fits and after finding a bad driver finally worked. SP2 is much more stable for us and I see no reason not to upgrade to the “norm”. Fear is nor a liberal trait! (slap, slap). From what I’ve seen on the Inet…if you have problems upgrading…you had a silent problem that just hadn’t exposed itself.

On my music comp I removed all the Net framework versions (1.1) and then installed version 2.

Set restore points befor you make changes and turn any anti anti software off while you install. Reboot and defrag and wipe out lingering temp files. (In dealing with my customers I find most computer problems start with bad maintenance practices…(not saying that applies to you!)).

I was trying out build 2080 last night and it just keeps getting better!

Come on Tom…get with the program! :)