Settings/Audio Devices ??

Which do I pick?

Running TASCAM US-122MKII with Dell Latitude D620.
In n-Track Settings/Audio Devices the TASCAM appears three times: MME: TASCAM US-122MKII, 1 - US-122MKII/144MKII and WDM: TASCAM US-122MKII.
Which one do I pick?
What’s the difference?
I know the TASCAM is talking to the laptop; my PC speakers work through a 1/8" to RCA adapter.
It’s more important that the unit talk to n-Track!


In terms of performance/latency in this order,


Be sure to select the same (ASIO for example) for both playback and recording.


Thanks for the reply. That makes ASIO #2 in my list, right? The Latitude laptop’s processor is a bit under powered (has plenty of memory,though). Does that impact the choice?


When accessing Settings/Sound Card Settings/Recording Mixer Settings, I get the following message:

Volume Control There is a problem with your sound hardware. To install mixer devices, go to Control panel, click on Printers and Other Hardware, and then click on Add Hardware.

I’ve never seen a Control Panel option labeled ‘Printers and Other Hardware’, ‘Printers and Faxes’, yes, but not the other.

What’s it all mean?


what version of Windows are you running? The message is saying that the hardware ( sound driver/hardware) for your computer is not installed to Windows. Go to the Control Panel of Windows , check int eh System > Devise Manager and see if your sound card is installed. If it is not there or it have the error marker (a yellow ! mark) then you will need to install the drivers for the hardware.

I’m running XP Professional Service Pack 3. In Device Manager, under Sound, video and game controllers the TASCAM is listed twice, TASCAM US-122MKII and TASCAM US-122MKII MIDI. Neither has the dreaded yellow triangle with !. I may just uninstall/reinstall the TASCAM anyway. Windows sometimes likes a second look. Thanks.


I get that prompt every now and again from Windows with my ONYX.

I just turn the mixer/interface off and back on usually solves it.

Installing a stand alone interface/breakout box is not always like a PCI or slotted soundcard, the main reason I can tell is it is not ALWAYS connected to the computer and powered on like a built in sound card is.

So…sometimes it is OFF when you boot up the computer, sometimes it is on for long lengths of time and communication stalls out.
In any event Windows is treating it like a new device that is just being “recognized” and wants to install the drivers for it, I just ignore that and go into Ntrack, provided the interface is powered up low and behold there it is, ASIO drivers and all just sitting there looking pretty waiting to be used… :laugh:

so windows thinks it’s new hardware…as long as it works in Ntrack what Windows thinks is no concern of mine. :p


The message that ‘There is a problem with your sound hardware.’ comes from n-Track not from Windows.

I have also discovered that in Windows Volume Control/Properties/Recording/Show the following volume controls, the box is empty. It should show Line In, External Mic and Internal Mic or something like that, right? I reinstalled the driver from the CD that came with the unit, no change. Do I need to update the driver from TASCAM? If so, do I download the 32 bit or the 64 bit? Thanks.


def get the newer drivers as they are almost always more current than the factory CD.


OK–Finally installed the latest drivers from Tascam.
Still have the same problems: In Windoze Volume Control/Properties/Recording, the box below ‘Show the following volume controls’ is blank. n-Track sound card settings says there is a problem and suggests I need to install hardware.
It appears the Tascam isn’t fully recognized (I have query out to them as well).
What gives?
The Tascam provides great playback, but if I can’t record, what’s the point?


you are not the first person to have an audio related problem with that model Dell.

back on 07 the forums were flooded with complaints because of the Sigmatel audio drivers and stereo mix and “record what you hear” were not showing up, a few guys had a hack on the inf that was a good work around.

try this:



Thanks, Mr. Dont, will check that out. Might dumping Sigmatel altogether help; can I even do that? This Dell was originally from a college laptop purchase program when one of my twins started university in 2007. When I mentioned the model number to one of the IT guys at work, he said they avoided the D620 completely because of defective parts. We purchase about a dozen laptops every year in the company, so now I know why certain models show up as college deals. Pitiful, eh?


I hear ya der if Dell excels at anything it is being constantly crappy when it comes to audio.

but there are many specific models of just about every brand that the same thing could be said of…you just have to know what model numbers they are and avoid them!

I look for TI chip stuff and Asus boards myself you find a laptop with a TI chipset firewire port and that my friend
is a good candidate for a portable DAW. :agree:
Older IBM’s, ASus, even some HP’s you might sacrifice a little in CPU but you make up for it in stability.

(no MR. here just kids in the hall
:laugh: )


OK, No more MR. Bottom line is will this Dell D620 record? Not sure what the asio4all thing was supposed to do, please clarify. But bottom line is bottom line. I need to record me, and I need to transfer vinyl to digital. If this machine can’t do it, I gotta re-figure the whole deal. Thanks.


as far as I know that Dell model what part of a deal with microsoft to thwart of audio piracy they disabled the AUDIO tabs and functions.

There is a work around.

Virtual Audio Cable


OK (sorry for the spotty attendance here, dealing with aged parents issues), A4A & Virtual Cable are installed; they show up in n-Track Settings/Audio Devices, but still have the problem with the n-Track error message with Sound Card Settings/Recording Mixer. Windows Volume Control shows nothing under Recording. It’s frustrating. I was hoping to get this resolved before I have to go to my twin daughter’s college graduations and they come home(one in NYC and one in Greencastle, IN four days apart, I know, poor planning on my part), they think I’m a computer whiz and like the recordings I make for them. Now I’m dead in the water. If I can’t get this Dell to cooperate, I’ll pick up an old desktop unit just for recording. Thanks.


Good grief… (I know I’m gonna kick myself tomorrow but I can’t let you suffer any longer…)

The Windows “Volume Control” has NOTHING to do with the Tascam. AT ALL… None. Zip. Zilch. Nada. Null. Goose eggs…

In n-Track Preferences you need to select the US122/144 (whatever) ASIO driver. I don’t remember how to open Prefs in n-Track… Ctrl + P? Whatever… make sure the ASIO driver is selected for BOTH imput AND output. Check the MIDI section of Preferences and DISABLE the MS Wavetable Synth. Enable the Tascam for MIDI in/out.

If all works as it should… (and it did on my US-122 and n-Track V5.?) then you should be able to play back a sample project or imported wave file or whatever with n-Track. Note: It SHOULD be fed out of the headphone jack and RCA jacks of the Tascam! NOT the Dell’s 1/8" stereo jack.

Back in V5 it used to be clicking the “Hammer” icon on the Record Vu meters let you select the recording ‘mode’ for the installed device(s). I assume it works similar now. I’m sorry I don’t remember the exact procedure for arming a track for recording using n-Track but if you consult the manual, it should help.

Good luck! :agree:


PS Will a Dell D620 record audio? H#ll yes… I know several guys who use them for just that… just not with n-Track. Including one who uses the Tascam US-122 I gave him. :)

I have a Tascam US-122. The driers have not been updated by Tascam since XP. I still use it with Windows 7 64bit and N-Track. have used it with N-Track for years. The Tascam is not the problem - I would chose the WDM drivers instead of ASIO myself.

When you are having probllems the MME is the one that will work on almost anything, but the WDM is better. Many folk prefer ASIO, but it is far less likely to work that WDM or MME if there are problems.

Thanks, Kaizen Wang.
‘The Windows “Volume Control” has NOTHING to do with the Tascam. AT ALL… None. Zip. Zilch. Nada. Null. Goose eggs’; well, not exactly, I think.
When you open n-Track’s Settings/Sound Card Settings/Playback Mixer Controls, what opens?
Windoze Volume Control.
In my case, regardless of the driver selected, ASIO or WDM, n-Track Settings/Sound Card Settings/Recording Mixer Controls shows the above quoted error message (‘There is a problem with your sound hardware…’) AND in Volume Control/Options/Properties/Recording, no devices are listed.
If Doze guys don’t recognize a device,
it ain’t there.
I’m currently stumped.